Unable to rescan vCenter on schedule
Problem: Unable to rescan vCenter application with version 2.14.205.
Cause:
There is an issue with the DataTTL column when setting the rescan for vCenters. Even though the value is set to 1 (which is the value for daily rescan) there rescan is happening.
To view the last successful scan date use
Select * From ApplicationScanHistory where ApplicationID in (Select ApplicationID From Application where applicationTypeEnumID = 12)
Order by LastSuccessfulDate
Confirm the vCenter is ApplicationTypeEnumID = 12
Resolution:
Set up a SQL Server Agent Job to run Daily,Weekly or Monthly
Job executes:
UPDATE ApplicationScanHistory SET AttemptCount = 1, NextScanDate = GETDATE()
WHERE ApplicationID IN
(SELECT ApplicationID FROM Application WHERE ApplicationTypeEnumID = 12)
Or Run the patch included
Line 44-55 has been added.
-- Reset any Application that DataTTL has expired since the last scan attempt UPDATE dbo.[ApplicationScanHistory] SET [AttemptCount] = @MaxFailures-1 WHERE [ApplicationScanHistoryID]IN ( SELECT [ApplicationScanHistoryID] FROM [ApplicationScanHistory] ash WITH( NOLOCK ) JOIN [Application] a WITH( NOLOCK ) ON a.[ApplicationID] =ash.[ApplicationID] WHERE ([ServiceTypeEnumID] = @ServiceTypeEnumID AND a.[DataTTL] is not null AND DATEADD(DAY, a.[DataTTL], ash.[LastAttemptDate]) <= @CurrentDate) AND ash.[AttemptCount] >= @MaxFailures);
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